Trade customers only UK business IT hardware · 01224 600337 Genuine stock · Trade pricing · Structured returns
Browse
Home Hubs & Switches D-Link DGS 1100-26MPV2 - Switch - smart - 24 x 10/100/1000 (...

D-Link DGS 1100-26MPV2 - Switch - smart - 24 x 10/100/1000 (PoE+) + 2 x combo Gigabit SFP - rack-mountable - PoE+ (370 W)

MPN DGS-1100-26MPV2 EAN 790069453342 D-Link
Trade customers only
£212.87 ex VAT £255.44 inc VAT
In stock · 3 available
Manufacturer datasheet →
Trade customers only: orders need a verified business account. Prices ex VAT; VAT is added at checkout.
Quote-led: a person reviews pricing and stock before you commit.
Genuine stock with the manufacturer warranty intact.
Structured returns with credit notes when something is wrong.
Questions? 01224 600337 — Aberdeen & across the UK.
Fresh data: stock and pricing updated 26 Oct 2026.

Description

Smart Web UI
The DGS-1100's web user interface is an easy way to manage Layer 2 features, such as VLANs, Spanning Tree Protocol (STP), link aggregation (static). With powerful security features like IGMP snooping, Static MAC, and Storm Control, the DGS-1100 Smart family is a versatile solution for environments that require easy to deploy and easy to configure solutions without added complexities.

Easy to Deploy and Manage
D-Link’s free Network Assistant (DNA) displays all connected devices and speeds up the first time configuration. The free D-View 7 Network Management System comes with a license for 25 nodes and 2 probes and full access to the management tools. Optional upgrade licenses allow you to broaden your network and analysis.

PoE and Poe+, with budgets up to 370W
The DGS-1100 Smart Series includes a range of high power budget PoE-enabled switches for businesses looking to power larger deployments of VoIP phones, wireless access points or network cameras.

Easy Troubleshooting
The DGS-1100 Series features Loopback Detection and Cable Diagnostics to help network administrators find and solve network problems quickly and easily.

Loopback Detection is used to detect loops created by a specific port and automatically shut down the affected port. The Cable Diagnostics feature is designed for network administrators to quickly examine the quality of the copper cables, recognise the cable type, and detect cable errors.

Green Technology
D-Link Green technology enables the DGS-1100 Smart series to save power without sacrifices. The majority of the family utilises a fanless design, for silent and energy efficient operation. All are IEEE 802.3az compliant and feature Link Status detection and Time-Based PoE (excluding DGS-1100-05PD and DGS-1100-08P models).

Surveillance Mode
Select Surveillance Mode in the Web UI to take advantage of easy‑to‑use surveillance features which also enable you to manage your surveillance network effortlessly. It automatically detects your security devices and segments them into a dedicated Auto Surveillance VLAN to handle video surveillance traffic securely and efficiently.

Specifications

Management features
Switch typeManaged
Switch layerL2
Quality of Service (QoS) supportYes
Web-based managementYes
ARP inspectionYes
MIB support• RFC768 UDP • RFC791 IP • RFC792 ICMP • RFC793 TCP • RFC826 ARP • RFC1213 MIB II • RFC1493 Bridage MIB • RFC1907 SNMPv2 MIB • RFC1215 MIB Traps Convention
Ports & interfaces
Basic switching RJ-45 Ethernet ports quantity24
Basic switching RJ-45 Ethernet ports typeGigabit Ethernet (10/100/1000)
Combo SFP ports quantity2
Network
Networking standardsIEEE 802.1D, IEEE 802.1w, IEEE 802.3af, IEEE 802.3at
Copper ethernet cabling technology10GBASE-T, 1000BASE-T
Port mirroringYes
Full duplexYes
Half duplexYes
Flow control supportYes
Link aggregationYes
Broadcast storm controlYes
Rate limitingYes
Auto MDI/MDI-XYes
Spanning tree protocolYes
Head-of-line (HOL) blockingYes
Auto-negotiationYes
VLAN supportYes
Virtual LAN featuresPort-based VLAN, Voice VLAN
Data transmission
Switching capacity52 Gbit/s
Forwarding rate38.69 Mpps
MAC address table8000 entries
Jumbo frames supportYes
Security
DHCP featuresDHCP client
IGMP snoopingYes
Security algorithmsSSL/TLS
MAC address filteringYes
Static port securityYes
Multicast features
Multicast supportYes
IPv4 multicast entries1
IPv6 multicast entries1
Number of multicast groups filtered1
Protocols
IPv4 & IPv6 featuresIPv4 FIB
Design
Rack mountingYes
Product colourBlack
Housing materialMetal
Performance
Flash memory16 MB
Noise level50.5 dB
FanlessYes
Power
Power supply includedYes
AC input voltage100 - 240 V
AC input frequency50 - 60 Hz
Power consumption (max)454.1 W
Power over Ethernet (PoE)
Power over Ethernet (PoE)Yes
Power over Ethernet (PoE) ports quantity24
Power over Ethernet plus (PoE+) ports quantity24
Total Power over Ethernet (PoE) budget370 W
Operational conditions
Operating temperature (T-T)-10 - 50 °C
Storage temperature (T-T)-40 - 70 °C
Operating relative humidity (H-H)0 - 95%
Storage relative humidity (H-H)0 - 95%
Heat dissipation287 BTU/h
Weight & dimensions
Width440 mm
Depth208 mm
Height44 mm
Weight2.8 kg
Logistics data
Harmonized System (HS) code85176990
Related

More in Hubs & Switches